티스토리 뷰

오늘 부터 eclipse galileo에 flash builder를 얹어서 사용하려고 새로나온 galileo를 깔았더니, 이런 에러는 내뱉었습니다.


흠...

초기화가 문제로 보여져서 ecslipse.ini파일을 편집해 봤습니다.


eslipcse.ini 내용

-startup
plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519
-product
org.eclipse.epp.package.jee.product
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m

-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m

빨간색으로 표시한 부분이 웬지 석연치 않습니다. 그래서 다음과 같이 변경했습니다.


-startup
plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519
-product
org.eclipse.epp.package.jee.product
-launcher.XXMaxPermSize
256m
-showsplash
org.eclipse.platform
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m

-- 을 -로 변경하고 M을 m으로 변경했습니다.  그리고 중복적인 구문이라 제거했습니다.

어짜피 주석 처리했던 것이니 제거하셔도 무방합니다. 해당 매개 변수는 이클립스가 실핼 될 때 할당될 최대 메모리 사이즈로 보입니다.



실행됩니다. ㅡ,.ㅡ;;
주석 처리를 하려면 제대로 해야죵~

이클립스 개발자님들~  고쳐주세요~ ^^



신고
댓글
댓글쓰기 폼